Page 2 of 2 FirstFirst 12
Results 26 to 40 of 40
  1. #26
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    308
    Okay Guys, I'm a happy bunny at last. The fixing kit arrived, is now installed, and hopefully I'll never need to do the passenger regulator again. I had a few issues along the way - it took ages to get the plastic rivets out, one of which I had to cut with a hacksaw! Also the top of the door card with the 2 metal clips didn't come off with the panel, so I removed all the (useless) staples and glued it back together.

    Big thanks to the OP of this thread (thanks Bob ) I've added my own pics to show the fixing kit which cost $79 including the pliers and tape plus shipping. It was a bit fiddly to do but got there in the end, I'm not sure why they supply 2 long and 2 short screws, 4 long ones made the job much easier

    Anyway, here's a video of the faulty window before starting so you can see what the symptoms are



    The repair kit

    IMG_0212.jpg

    My faulty regulator, you can see in the bottom left where the plastic tube had come out of it's joint (note also the holes in the plastic corners of the regulator, they serve no purpose, but the metal fixing bracket uses these - so why did Dodge not do this simple bracket at the factory?? - it would have saved a lot of warranty claims and busted regulators

    IMG_0219.jpg

    After removing the 3 screws on the motor bracket, disassemble, fit the repair kit, then replace the motor screws. Use the screws and nuts to fix the ends - notice that one side is 'face up', the other is 'face down' as per the instructions supplied) The metal fixing bracket is supplied flat, so the pliers are used to bend the ends where the screws go.

    IMG_0225.jpg

    Wrap the electrical tape round the metal fixing bracket and the window regulator tube at both ends

    IMG_0226.jpg IMG_0227.jpg

    Now the fix is complete, it was still hard to get the assembly back in the door, but you can afford to be quite rough with it as the metal makes it (hopefully) impossible to snap the plastic tubing.
    Last edited by sonicbloo; 07-14-2019 at 03:09 PM.

  2. #27
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    308
    Finally here are a couple of pictures of the metal clip which holds the front of the window glass to the regulator, just to make things clearer.

    IMG_0229.jpg

    and this is where it fits, I practised on the garage floor before putting it back in the car

    IMG_0230 (2).jpg

  3. #28
    A big thanks to both 01bigsapphirebob and sonicbloo, gave me the courage to try tackling this and everything works great except at the last 1 or so inches when rolling window up it makes a rattling sound, like it is rubbing on something and getting slightly stuck. Anyone else experience this? I've readjusted the window a little and it still does it. Other than that, it does fine when the door is closed and everything.

    As far as the repair kit, I felt like it was a bit jankity and if I had to do it all over I would probably spring for the new regulator instead. And I might still if I can't get this rattle resolved.

    Also, upon inspection, my plastic sleeve on the regulator was not cracked or broken anywhere that I could see, but it was making the same noises as sonicbloo's in the video.

    A few pics from my installation:

    I tried to get pics of where the metal tabs were to help others out bc I had a heck of time finding the front one. It felt like it was pushed further down.

    20190724_194422.jpg


    Here's a side view, peeping in from where the top rivet was:

    20190724_194121.jpg


    Pic of the door handle cable, gives you an idea of how you need to wrangle it around to get it out of it's slot:

    20190724_195724.jpg


    Pic of getting the regulator out, I just shoved a small bit out the top and it came out pretty easy:

    20190724_204217.jpg


    See how the repair kit doesn't quite match the bend in my sleeve? Not sure if others have the same issue or not, but it bothered me:

    20190724_211618.jpg
    2008 VVO Viper | ACR-X Headers | Hi-Flow Cats | Smooth Tubes | Arrow PCM | Gen V Intake

  4. #29
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    308
    Quote Originally Posted by v10CodeMonkey View Post
    A big thanks to both 01bigsapphirebob and sonicbloo, gave me the courage to try tackling this and everything works great except at the last 1 or so inches when rolling window up it makes a rattling sound, like it is rubbing on something and getting slightly stuck. Anyone else experience this? I've readjusted the window a little and it still does it. Other than that, it does fine when the door is closed and everything.]
    Could the window be catching on one of the nuts that is supplied with the repair kit? Mine was - so I removed it and inserted it the other way round so the nut was on the opposite side. I'm glad I tried it before putting the door panel back on

    Don't worry about the repair kit not quite following the shape of the plastic tube, it shouldn't matter

  5. #30
    VOA Mamba Member
    since 2019
    Capital Vipers (DC/DE/MD/VA)

    Join Date
    Sep 2018
    Posts
    86
    Bumping this old thread. Awesome write ups. I ordered a new actuator more than a year ago. Months after that I found out about the repair kit. Assembled the repair kid ahead of time and today finally installed it.

    Here are my take awaya:
    -def test the window before assembling the door card. One of the repair kit nuts was hitting the window bracket. I hat to flip the nut orientation and gently pry the metal reinforcement of the repair kit towards the middle of the car.
    -while in there I placed a bunch if sound deadening. My door slipped/sagged, so had to adjust the door to get everything to line up again.

    Thanks for all who posted ahead of time to make this a breeze.

  6. #31
    VOA Member
    since 2013
    NY/CT

    Join Date
    Aug 2014
    Location
    Wappingers Falls, NY
    Posts
    264
    This was very helpful, I had that bad groan as the glass traveled the uppermost inch of travel. I ordered the stainless steel "spine" but otherwise the project is as described.

    Some added hints:
    The first three plastic rivets-push the center in and it releases the same as if you could pull it out.
    The instructions dont highlight this, but I removed the outer plastic rub strip also (the small screws are accessible through holes in the door.) This provides more space to poke the front tube of the regulator upwards.
    The stainless spine worked for me, nothing had broken and the noise was the plastic tube rotating in the housing. With the support, it's quiet.
    Be more forceful when installing the spine assisted regulator.

    This is one of those projects that takes 90 minutes the first time and 30 minutes the next time.

  7. #32
    Thanks so much for this thread. Made all the difference. I guess I should have read all the posts as I just see where Tom above told me how to remove the pop rivets. Well, I destroyed a couple before I figured it out!!!!

  8. #33
    [QUOTE=01sapphirebob;254404]

    So first things first, open your door. :P

    Next, There are three pop rivets in the door. You'll need to remove them.



    First of all, thanks a lot for documenting and posting this... Extremely helpful... Gave me the courage to try and tackle it on my own!!

    I did the first step successfully... i.e. "open the door" 😃

    And now I am stuck at step 2... Taking the rivets out!

    What's the best way to take them out?? Is there a special tool for this? Does the whole thing come out or just the outer part?

    It's halfway out but despite pulling it quite hard, it's not coming out.

    Appreciate any help!!

  9. #34
    Enthusiast Old School's Avatar
    Join Date
    Dec 2018
    Location
    North Alabama
    Posts
    444
    Quote Originally Posted by Raheel View Post
    What's the best way to take them out?? Is there a special tool for this? Does the whole thing come out or just the outer part?

    It's halfway out but despite pulling it quite hard, it's not coming out.

    Appreciate any help!!
    That center circle pulls out first, maybe 1/2", and unlocks the rivet. Pry with a little screwwdriver.
    Last edited by Old School; 03-13-2020 at 04:26 PM.

  10. #35
    VOA Member
    since 2020
    Ohio
    Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    4,163
    Quote Originally Posted by Old School View Post
    That center circle pulls out first, maybe 1/2", and unlocks the rivet. Pry with a little screwwdriver.
    Negative...push it IN first, then you can remove the outer circle. To reinstall, the big circle goes in first, followed by the center pin, pushed in until it is flush.
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Manifold | HPTuners | 3.55s | MCS | DSS Axles | McLeod RST | 11.027 @ 130.06 (Vid), 1.78 60' (+1,622 ft DA, w/ 3.55s & Hoosier Drag Radials)

  11. #36
    Quote Originally Posted by Steve M View Post
    Negative...push it IN first, then you can remove the outer circle. To reinstall, the big circle goes in first, followed by the center pin, pushed in until it is flush.
    Thanks for your help!!

    Just got it out. You have to push it in first and then remove the the big circle.

    Thanks again. You guys are awesome!!

  12. #37
    Enthusiast Old School's Avatar
    Join Date
    Dec 2018
    Location
    North Alabama
    Posts
    444
    Quote Originally Posted by Steve M View Post
    Negative...push it IN first, then you can remove the outer circle. To reinstall, the big circle goes in first, followed by the center pin, pushed in until it is flush.
    Yep, this is correct, been a few years since I released one (wasn't even a Viper).

  13. #38
    VOA Mamba Member
    since 2014
    Western Reserve
    mamba184's Avatar
    Join Date
    Jan 2014
    Location
    Bridgeport, WV
    Posts
    56
    Bob -

    Many thanks for taking the time to take pictures and develop a step by step procedure regarding the window regulator replacement. Also a note of appreciation to FrgMstr, sonicbloo, V10CodeMonkey, Zubik and others for the helpful hints. There is no way I would have attempted this task without this great tutorial.

    I almost hate to admit but it took me several hours over 2 days to remove/repair/replace my window regulator. I even made up some new cuss words during the process! But I learned a ton from the experience and will be ready to tackle the other side should the need arise.

    Thanks again!!!

  14. #39
    Just to update the group, I ordered a new regulator (revision AI) but when the part arrived I noticed the actual part said it was rev. AH even though everywhere else on the box, it said AI. So I returned that part and started looking for another one.

    I found someone selling (new) window regulators without a motor and since there was nothing wrong with the motor I decided to give that a try. It worked like a charm. I used the original motor with the new regulator. The window is fixed now!!

    The eBay seller seems to have 3 more available in case any member here needs it for future repairs.

  15. #40
    Enthusiast bulitt's Avatar
    Join Date
    Sep 2017
    Location
    NC
    Posts
    90
    Great Thread!!! Thanks to the OP and Following Contributors!

    Driver side Regulator crapped the Bed. 2008. Symptoms -window would not index. No noise or other issues
    Ordered the kit but really doesn't seem to work very well. Someone described it as "Wonky"?
    If your tube is broken through 100% the spring tends to push the tube apart. It must be brought together when fitting the kit.
    And the Short side of the kit seemed to be "Too short" resulting in the plastic tube kinking at the break.
    So I didn't have any luck assembling it. Not sure why the one side of the repair kit is Too short? Possibly changes to the OEM regulator assemblies over the years?

    Replacement Regulators are now 450$ + just under 500$ with tax and shipping.
    And I purchased the repair kit for 80$, so into close to 600$ now.
    New Regulator appears to be assembled in Mexico and the Motor says France on it?

    Will be wrapping the new regulator plastic tubing with electrical tape which should make it stronger yet still pliable.

    The design of this whole thing is Wonky...


 
Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •