Results 1 to 5 of 5
  1. #1
    Enthusiast thethom's Avatar
    Join Date
    May 2016
    Location
    Greensboro, NC
    Posts
    25

    Gen V Camshaft Position Sensor Replacement

    Hey all,

    Did a writeup with lots of pics on this in the how to section. It's a common issue that can completely paralyze a Gen V Viper, yet can be taken care of in one's garage for $15. I couldn't find a detailed how to anywhere else and I believe it's a very different process for the previous generations. Hope this helps someone in need.

    https://driveviper.com/forums/thread...or-Replacement

  2. #2
    Enthusiast Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    3,621
    Nice write up. My Gen 4 went into limp mode at the drag strip a couple times this past fall, and it threw a camshaft position sensor code. I was able to make a couple of clean passes after that, but I may end up having to go this route myself.
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Manifold | HPTuners | 3.55s | MCS | DSS Axles | Nth Moto Clutch | 11.04 @ 129.7, 1.81 60' (-100 ft DA, w/ 3.55s & MT Drag Radials)

  3. #3
    Enthusiast thethom's Avatar
    Join Date
    May 2016
    Location
    Greensboro, NC
    Posts
    25
    It was an overall easy fix. That being said, I'm not certain on the location of the CPS of the Gen 4. This may only apply to the Gen V.

  4. #4
    Regional Membership Director
    VOA Mamba Member
    since 2013
    Indiana/Kentucky
    Steve-Indy's Avatar
    Join Date
    Oct 2013
    Posts
    2,810
    Similar spot on Gen IV.
    I don't send or receive "PM's" since I prefer DIRECT communication.

  5. #5
    Enthusiast thethom's Avatar
    Join Date
    May 2016
    Location
    Greensboro, NC
    Posts
    25
    Thank you Steve.


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •