Page 1 of 4 123 ... LastLast
Results 1 to 25 of 88
  1. #1

    Picking up my first Viper the day after tomorow deposit sent SIGHT UNSEEN

    hey guys

    long time corvette owner getting my first viper in 2 days.

    I sent the deposit sight unseen, the car is apparently owned by an older guy who rarely drives it, im dealing with his son now.

    Car is a rebuilt status, repaired close to ten years ago

    30 000 miles or so

    2005 convertible

    Frist basic questions are what should the oil pressure be on idle when its hot?

    Do these engines make any signature type of clicks or knocks inherintly? In the corvette world some of the older Ls engines, and some of the newer ones, have alot of chatter when cold, are the viper engines the same?

    Il be going for a very nice test drive, listening closely , going through all the gears, buttons and checking the gauges for abnormalities.

    i can check paint work quite well so no worries there, just mechanically, anything in particular i should be looking for?

    Thanks
    Last edited by 1Willy1; 05-12-2021 at 04:13 AM.

  2. #2
    Supporting Vendor JonB ~ PartsRack's Avatar
    Join Date
    Oct 2013
    Location
    Up The River..[Columbia River Gorge near Portland OR]
    Posts
    3,678
    Congrats.

    G3 Oil Pressure is very high, 80-90+ on cold start. Can be 50-60 while running / cruising.

    Pushrod V-10 mild vlave clatter when cold idle

    Rear-End Clunk common during roll-off especially backing up.

    Hot sills can frighten or even scorch bare legs!

    Shifting 1 - 4 is like Vettes. Tranny is virtually identical

    Check your tire date codes. 05 came with Run-Crap hockey pucks.

    Your TPMS are probably bad / dead

    Good Luck
    Jon "JonB" Brobst ~~~~:<~ JonB@PartsRack.com


  3. #3
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    340
    Good info from JonB

    Also check leaks from oil cooler pipes

    Make sure windows go up/down with no noises

    Check fan motor works on all speeds

    The 3 things I listed are the only issues I've had in 6 years. All were DIY fixes costing a total of approx $500

    Glad to hear the clunks and rattles are 'normal' as mine has those!

  4. #4
    It’s like JonB was right in the cockpit of my car. To the “T”, haha.

    Congrats man. Enjoy the ride.

  5. #5
    Thanks alot guys appreciate it

    I'll listen for the rear end and any abnormal engine noises, windows and watch the oil temps

    How would I know if the fans are on ir not ? Can I hear it from the cockpit?

  6. #6
    Supporting Vendor JonB ~ PartsRack's Avatar
    Join Date
    Oct 2013
    Location
    Up The River..[Columbia River Gorge near Portland OR]
    Posts
    3,678
    Quote Originally Posted by 1Willy1 View Post
    Thanks alot guys appreciate it

    I'll listen for the rear end and any abnormal engine noises, windows and watch the oil temps

    How would I know if the fans are on ir not ? Can I hear it from the cockpit?
    It will cycle in your driveway on a warm day
    Jon "JonB" Brobst ~~~~:<~ JonB@PartsRack.com


  7. #7
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    340
    Quote Originally Posted by 1Willy1 View Post
    Thanks alot guys appreciate it

    How would I know if the fans are on ir not ? Can I hear it from the cockpit?
    Sorry, I meant the fan that works the heater / air con inside the car, my fan motor (blower motor?) siezed up due to water ingress

  8. #8
    My blower motor had to be fixed in my car before I would take delivery. I had a reputable mechanic fix it for $150.
    I’m not sure what caused it to malfunction but it was an easy fix.

  9. #9
    Thanks guys ..had the dealer check out the car

    It has a check engine light on, throwing O2 sensor codes for both sides , examination showed no cats , no 02 sensors and headers installed.

    The fan blower motor as me toned earlier is seized

    Wheel bearing and some bushings have play.

    One rear strut is leaking as is the two oil cooler lines

    Going to try and knock off a few grand for these repairs

    Anything I should be concerned with here?

    Thanks

  10. #10
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    340
    Quote Originally Posted by 1Willy1 View Post
    Thanks guys ..had the dealer check out the car

    It has a check engine light on, throwing O2 sensor codes for both sides , examination showed no cats , no 02 sensors and headers installed.

    The fan blower motor as me toned earlier is seized

    Wheel bearing and some bushings have play.

    One rear strut is leaking as is the two oil cooler lines

    Going to try and knock off a few grand for these repairs

    Anything I should be concerned with here?

    Thanks
    Sounds like minor issues to me, so nothing too serious, but good haggling points for getting the price down

    On my car, the fan/blower motor seized a few weeks into ownership. When getting to the motor, remove the plastic cowl carefully as the ends near the doors break off. Check if the motor is actually seized (mine was rusted due to water getting in) it is likely you may need a new resistor too, as this goes pop at the same time. Part No's are 5093248AB and 5014212AA. I stopped future problems by creating a safe path using silicone sealer, for any water coming off the windshield, so it doesn’t end up in the motor.

    blower motor.jpg

    blower motor resistor.jpg

    Oil cooler lines had to be replaced on mine, I got OEM replacements as the modified ones were on back order, and 6 years on they are still ok

    As I said earlier, these issues cost me less than $500 for the parts

    The hole where the motor sits above the passengers legs, water easily finds its way into this hole!

    blower motor hole.png
    Last edited by sonicbloo; 05-19-2021 at 03:26 PM.

  11. #11
    Thanks sonic appreciate the detailed response alot of good info there

    Good news is I now own the car and driving it 22 hours back home after flying to pick it up.

    This is definitely a car that needs some loving care , but for the price I'm super happy to own it

    Thd engine runs like a swiss watch , gauges all where they shouid be, fires up cold immediately no hesitation.

    The main issue it has is the return spring on the shifter doesn't go back to neutral.

    I heard many have dealt with this, some have fixed it with springs or alignment , new fluid or anti venom mod. Also it struggles going into 6th gear , I have to go from 5th to neutral and then to 6th, hoping I dont need a rebuild but preparing fit the worst.

    I got $3000 more off the price for this issue , $18 000 total off the asking price.

    I did well considering how the process have skyrocketed here.

    Anyone have any luck repairing these shifters without a rebuild?

    Thanks alot guys, cant tell you how happy I am with this car so far !!

  12. #12
    Enthusiast
    Join Date
    Nov 2013
    Location
    Chandler, AZ
    Posts
    2,405
    Quote Originally Posted by 1Willy1 View Post
    The main issue it has is the return spring on the shifter doesn't go back to neutral.

    I heard many have dealt with this, some have fixed it with springs or alignment , new fluid or anti venom mod.

    Anyone have any luck repairing these shifters without a rebuild?
    The first thing to determine is whether it is an OEM shifter or aftermarket and which aftermarket it is. Replacing the shifter is a very common modification. It was easy to disassemble the aftermarket B&M shifter I had and change to a stronger spring. I do not know about the others.
    Jim

  13. #13
    Thanks Jim

    Saw a few threads on that, it's definitely NOT a short shifter

    Ideally I'd like to get an MGW so I'll start looking for that and ask for stiffer springs hope that helps

    Thanks

  14. #14
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    340
    We're still eagerly awaiting pictures Willy!!!!!

  15. #15
    Lol Sonic

    Just arrived home last night, today I plan to start my restoration

    I will document with PHOTOS

  16. #16
    I'm.a member of lexus, vette, jaguar and many other forums

    This is the only one with no option to upload photos , is it just me or is this how it is?

  17. #17
    Regional President
    VOA Member
    since 2013
    United Kingdom
    Fatboy 18's Avatar
    Join Date
    Oct 2013
    Location
    South of London, Surrey
    Posts
    7,337
    Quote Originally Posted by 1Willy1 View Post
    I'm.a member of lexus, vette, jaguar and many other forums

    This is the only one with no option to upload photos , is it just me or is this how it is?
    Along the tool bar when posting, at the far end of it 3rd icon from the end is a picture frame. Click on that and then it gives you two options, "from computer" or URL. Choose computer (which can be laptop, Ipad or phone) "Choose File" Select picture and it will convert it with a code to post, then press Upload file. Then you should see [ATTACH=CONFIG] a number[/ATTACH]

    If you press go advanced you can see you post configured before actually posting it

    IMG_20190428_104511.jpg
    This pic just uploaded from my laptop for demo
    Last edited by Fatboy 18; 05-25-2021 at 06:51 AM.

  18. #18
    Thanks fatboy

    I had to log in a different way now I finally have the ability to upload

    Anyways just to update my car is a rebuilt and the paint was slightly orange peeled and overall the car needs alit of love

    I started wetsanding the panels with 1500, thrm 2000 then a 3 stage compound and polish , I will then ceramic coated whole car afterwards

    Car neededca thorough detailing and lots of little things

    Curious, my car came with two keys but only one fob

    If I lose the fob is it possible to still get in and out , and use the car? If so where is the door key lock ?

    Thanks
    Attached Images Attached Images

  19. #19
    VOA Member
    since 2015
    United Kingdom
    sonicbloo's Avatar
    Join Date
    Feb 2015
    Location
    Northern England
    Posts
    340
    Quote Originally Posted by 1Willy1 View Post

    Curious, my car came with two keys but only one fob

    If I lose the fob is it possible to still get in and out , and use the car? If so where is the door key lock ?

    Thanks
    I'll send you a private message regarding getting into the car without a fob

  20. #20
    Thanks sonic

  21. #21
    Enthusiast labtec's Avatar
    Join Date
    Mar 2014
    Location
    Maryland
    Posts
    152
    To manually unlock with key, look under drivers door along the inset forward edge. There is a key lock to unlock the door. Because it is never used, when you find it try unlocking door and lubricate if required so it is functional should you ever need it.

  22. #22
    Appreciate that labtec, found it

    Now I'm not so worried if I ever lost my fob lol

  23. #23
    Supporting Vendor JonB ~ PartsRack's Avatar
    Join Date
    Oct 2013
    Location
    Up The River..[Columbia River Gorge near Portland OR]
    Posts
    3,678
    We have Fobs and Keys at www.ViperPartsRackAmerica.com.

    And MGW or IPS shifters too. at www.ViperPartsRack.com

    TIRES TOO, fresh and new

    Congrats,and Thanks
    Jon "JonB" Brobst ~~~~:<~ JonB@PartsRack.com


  24. #24
    Hi Jon

    You have mgw in stock ?

    Can I also get the strongest springs ?

    Pls pm me if they are actually in stock now thanks

  25. #25
    And sorry for all the questions guys, wondering how to check the Tpms pressures? I dont see any way to do it on the dash which is the whole point of having them lol


 
Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •