Results 1 to 10 of 10
  1. #1
    Enthusiast Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    4,576

    2015 Viper Oil Pressure Drop

    Note: this is not my Viper.

    I was clicking around on YouTube, and came across this new video review of a 2015 Viper (TheTopher Channel):



    Looks like it just posted yesterday.

    Bottom line: fast forward to the 6:00 mark and watch the oil pressure gauge as he accelerates in first gear. The oil pressure drop is the first thing I noticed, followed by the red flashing.

    The oil pressure drops pretty bad as the RPMs climb at other parts in the video as well.

    Looks like the owner's name is Tom, and he'd be located in Michigan.

    I don't know if anyone knows the YouTube channel owner or the Viper owner, but if you do, someone needs to make sure this guy knows what's going on.

    I left a comment on the channel page, but I have a feeling it's going to get lost in the sea of comments already there.
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Man. | UDP | HPT | 3.55s | MCS | DSS Axles | Nth Moto Clutch | 10.86 @ 130.66, 1.68 60' (+1,344 ft DA, w/ 3.55s & Hoosier Drag Radials)

  2. #2
    VOA Mamba Member
    since 2013
    Colorado/Montana/Utah/Wyoming
    ViperGeorge's Avatar
    Join Date
    Oct 2013
    Location
    Greenwood Village, CO
    Posts
    3,481
    Yikes! It could be a bad oil sender, they are crap, but then again if it isn't he will grenade his motor soon.
    2017 ACR/TA in 2014 TA Header Orange, #4 of 10.
    2008 Vert in Viper Bright Blue with silver stripes.
    2014 GTS in white with gunmetal stripes. I'm also one of the original 100's

  3. #3
    Enthusiast Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    4,576
    Quote Originally Posted by ViperGeorge View Post
    Yikes! It could be a bad oil sender, they are crap, but then again if it isn't he will grenade his motor soon.
    Hadn't considered that one, but remember now that that could also be an issue.

    Either way, I'd want to know for sure one way or the other.
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Man. | UDP | HPT | 3.55s | MCS | DSS Axles | Nth Moto Clutch | 10.86 @ 130.66, 1.68 60' (+1,344 ft DA, w/ 3.55s & Hoosier Drag Radials)

  4. #4
    VOA Mamba Member
    since 2015
    New Jersey

    Join Date
    May 2015
    Location
    Watchung,NJ
    Posts
    491
    Hmm, he could also be down a couple of quarts of oil.
    2013 GTS, 2018 Trackhawk,2018 Jeep Grand Cherokee Overland, 2010 HARLEY SUPER GLIDE CUSTOM

  5. #5
    VOA Member
    since 2013
    Central North Florida
    ViperSRT's Avatar
    Join Date
    Nov 2013
    Location
    Rochester Hills, MI & Orlando, FL
    Posts
    1,294
    Good catch. I expect it is low oil level but in any way needs to be checked soon.

  6. #6
    Enthusiast Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    4,576
    Update: message received by the owner, so mission accomplished.

    Sounds like it was low on oil according to him - he topped it off, and everything appears to be back to normal.

    Best of luck to him, and thanks to all for looking!
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Man. | UDP | HPT | 3.55s | MCS | DSS Axles | Nth Moto Clutch | 10.86 @ 130.66, 1.68 60' (+1,344 ft DA, w/ 3.55s & Hoosier Drag Radials)

  7. #7
    Regional Membership Director
    VOA Mamba Member
    since 2013
    Indiana/Kentucky
    Steve-Indy's Avatar
    Join Date
    Oct 2013
    Posts
    3,471
    Great catch, Steve !!
    I don't send or receive "PM's" since I prefer DIRECT communication.

  8. #8
    Hopefully no damage was done though. I still can't see how the driver (was the driver the owner?) didn't notice that. I mean, it's right there in your face. Another reason I always drove with the Perfomance Pages up.
    2013 Dodge Viper SRT Track Pack Adrenaline Red
    2016 Dodge Ram 1500 Bighorn Quad Cab 5.7L 4x4 Blue Streak Pearl

  9. #9
    Enthusiast Steve M's Avatar
    Join Date
    Oct 2013
    Location
    Dayton, OH
    Posts
    4,576
    Quote Originally Posted by swexlin View Post
    Hopefully no damage was done though. I still can't see how the driver (was the driver the owner?) didn't notice that. I mean, it's right there in your face. Another reason I always drove with the Perfomance Pages up.
    Driver was not the owner in that video - owner was in the passenger seat.
    2008 SRT-10 Coupe - Venom Red Metallic w/ White Stripes - 1/4 Mile Passes (YouTube)
    High Flow Cats | Gen 5 Intake Man. | UDP | HPT | 3.55s | MCS | DSS Axles | Nth Moto Clutch | 10.86 @ 130.66, 1.68 60' (+1,344 ft DA, w/ 3.55s & Hoosier Drag Radials)

  10. #10
    VOA Mamba Member
    since 2013
    Central North Florida
    No hemi's Avatar
    Join Date
    Oct 2013
    Posts
    787
    My Calvo H/C build has been doing that, I just replaced all valve springs, retainer and a valve( valve spring broke) and a new piston, I checked the oil level and it was ok, My other gen5 used to do it but it was low OIL level, wonder what might be causing it ( doesn't do it every time) on my car, oiling issues should have been fixed with the calvo build, so hopefully a bad sensor
    2013 GTS BLK Calvo H+C, "RTTLSNK"
    2020 Ram Rebel (white) "M4YHEM (daily)
    2003 SRT10 Blk "SHESFST"


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •