Results 1 to 6 of 6

Thread: Gen 3

  1. #1
    VOA Member
    since 2019
    Southern California

    Join Date
    May 2017
    Location
    San Diego,California
    Posts
    7

    Gen 3

    Please help, what's caused the RPM to fluctuate from 600-1.5K on idle after hard acceleration to 5.5 k. Novi 2000 supercharger was installed about 2 years ago with no problem until now. Thank you in advance.
    Nick

  2. #2
    VOA Mamba Member
    since 2021
    St. Louis
    13COBRA's Avatar
    Join Date
    Mar 2016
    Location
    Kansas City, MO
    Posts
    3,421
    Quote Originally Posted by Nick100459 View Post
    Please help, what's caused the RPM to fluctuate from 600-1.5K on idle after hard acceleration to 5.5 k. Novi 2000 supercharger was installed about 2 years ago with no problem until now. Thank you in advance.
    Nick
    That is weird. No other issues? Runs smooth up top?

    What's it like on a cold start idle?

    Does it still have the factory throttle body?
    Last edited by 13COBRA; 2 Weeks Ago at 04:00 PM.
    Nick Anderson

    VCC #003

  3. #3
    Sounds Like the blow off valve is stuck closed. Had the same thing on a supercharged 370Z
    You can teach a dog to fetch, therefore you teach a potato to dance! “Amazingly Bad Analogy”

  4. #4
    VOA Member
    since 2019
    Southern California

    Join Date
    May 2017
    Location
    San Diego,California
    Posts
    7
    What's it like on a cold start idle?
    The idle is fine prior to this happening, now is fluctuating

    Does it still have the factory throttle body?
    Not sure of this after Todd Abram installed the supercharger.

  5. #5
    Regional Membership Director
    VOA Mamba Member
    since 2013
    Indiana/Kentucky
    Steve-Indy's Avatar
    Join Date
    Oct 2013
    Posts
    3,544
    See Todd.
    I don't send or receive "PM's" since I prefer DIRECT communication.

  6. #6
    VOA Mamba Member
    since 2021
    St. Louis
    13COBRA's Avatar
    Join Date
    Mar 2016
    Location
    Kansas City, MO
    Posts
    3,421
    Quote Originally Posted by Nick100459 View Post
    What's it like on a cold start idle?
    The idle is fine prior to this happening, now is fluctuating

    Does it still have the factory throttle body?
    Not sure of this after Todd Abram installed the supercharger.
    I'd call Todd.
    Nick Anderson

    VCC #003


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •